The Joel on Software Discussion Group (CLOSED)

A place to discuss Joel on Software. Now closed.

This community works best when people use their real names. Please register for a free account.

Other Groups:
Joel on Software
Business of Software
Design of Software (CLOSED)
.NET Questions (CLOSED)
TechInterview.org
CityDesk
FogBugz
Fog Creek Copilot


The Old Forum


Your hosts:
Albert D. Kallal
Li-Fan Chen
Stephen Jones

German???

The discussion forum has decided to display some of the links (logoff, new topic etc.) in German.

Does that only happen to me? Why?
Andrew Brehm Send private email
Friday, May 11, 2007
 
 
Is the primary language on your browser set to German?
Michael H. Pryor Send private email
Friday, May 11, 2007
 
 
Ja, was ist denn das fuer ein Pfusch?
Paranoid Android Send private email
Friday, May 11, 2007
 
 
This message board always had a problem with the ACCEPT_LANGUAGE HTTP header. The previous version used to show message dates in the wrong language when I browsed with Camino.

I'm using OmniWeb now and things are in German. My ACCEPT_LANGUAGE header is:

"en, ja;q=0.94, fr;q=0.88, de;q=0.81, es;q=0.75, it;q=0.69, nl;q=0.62, sv;q=0.56, nb;q=0.50, da;q=0.44, fi;q=0.38, pt;q=0.31, zh-hans;q=0.25, zh-hant;q=0.19, ko;q=0.12"

Also, the site is totally scrambled in Firefox (Mac 2.0.0.3). Firefox (Windows 2.0.0.3) looks fine. It's the first time I've ever seen Firefox render differently on different platforms.
Nate Silva Send private email
Friday, May 11, 2007
 
 
This is happening to me as well, but only in Camino (Mozilla's Mac-centric browser). Doesn't happen in Firefox on the same machine.
marty Send private email
Saturday, May 12, 2007
 
 
Yes, it's trying to be really smart. The buttons are german, even though I set it to english in the preferences.

I really don't want native-language buttons in an english-language forum. If I had problems with english, I wouldn't be here anyway.
Matthias Winkelmann Send private email
Saturday, May 12, 2007
 
 
Some buttons appear in German for me, too.  I'm using Opera 9.2 and the first preferred language is set to English.  German is the second one.  Does the forum software search preference from back to front?
Chris Nahr Send private email
Saturday, May 12, 2007
 
 
"Is the primary language on your browser set to German?"

No. It's notwhere near that simple. :-)

I speak German but everything in my computer is set to British English plus Irish English and Hebrew as keyboard layouts.

German is the second-favoured language in System Preferences. I assume the browser picks that up.

I'll try set it to French and see whether it has an effect.
Andrew Brehm Send private email
Saturday, May 12, 2007
 
 
I set the second-favoured language to French and the links still appear in German.

I don't know where it gets "German" from. That was the only setting set to "German" I can think of.

The position here is Ireland.
Andrew Brehm Send private email
Saturday, May 12, 2007
 
 
Same problem here. I'm using Opera 9.2 (Mac OS X - Intel). My Accept-Language header is:

en,fr;q=0.9,ja;q=0.8,de;q=0.7,es;q=0.6,it;q=0.5,nl;q=0.4,sv;q=0.3,nb;q=0.2
Methy
Saturday, May 12, 2007
 
 
Played a bit with the language settings in Firefox (Tools > Options > Advanced > General > Languages).

- If English is the only language, everything is English.
- If English is the first language and German the second, the login links and reply buttons are German.
- If German is the first language and English the second, the login links, the reply buttons and the dates are in German.

So whenever possible, the discussion board speaks German.
Maybe Fog Creek is looking for funding from the Goethe Institute? ;-)
Arend
Sunday, May 13, 2007
 
 
I'm seeing the same thing in Opera 9.02 on OS X. Previous versions of the board displayed in French on this particular browser.
clcr
Sunday, May 13, 2007
 
 

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics
 
Powered by FogBugz